Bold Page Builder < 5.9.8 - Contributor+ Stored XSS via Multiple Shortcode Element Attributes
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Bold Page Builder WordPress plugin before 5.9.8 does not sanitise and escape several shortcode attributes before outputting them in HTML attributes, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when a user views the affected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Bold Page Builder | before 5.9.8 | 5.9.8 | Patch available | CNA |
- Bold Page Builder VendorUnknown Affected before 5.9.8 Fixed in 5.9.8 Patch available CNA
Remediation
- Fix · CNA Bold Page Builder (Unknown) Fixed in 5.9.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Bold Page Builder 5.9.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-57781 Bold Page Builder < 5.9.8 - Contributor+ Stored XSS via bt_bb_button/bt_bb_headline/bt_bb_icon URLPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2026-84022
- 2026-10-03 Alias added: GHSA-5q9q-vpgg-v6hg
References
Sources
- CVE-2026-84022 · CVE Program
- CVE-2026-84022 · NVD
- FIRST EPSS
- GHSA-5q9q-vpgg-v6hg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences