The Post Grid < 7.9.5 - Contributor+ Stored HTML/iframe Injection via wp_kses_post Allow-List Widening
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid WordPress plugin before 7.9.5 does not limit an expansion of the WordPress allowed-HTML list to its own markup and applies it site-wide, allowing users with the Contributor role and above to store iframe, style and input elements that are normally stripped from their content, leading to HTML injection (phishing frames, CSS defacement and spoofed input forms) that renders to any visitor and to administrators reviewing the content.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | The Post Grid | before 7.9.5 | 7.9.5 | Patch available | CNA |
- The Post Grid VendorUnknown Affected before 7.9.5 Fixed in 7.9.5 Patch available CNA
Remediation
- Fix · CNA The Post Grid (Unknown) Fixed in 7.9.5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-84151
- 2026-10-03 Alias added: GHSA-93v8-jc63-2mm4
References
Sources
- CVE-2026-84151 · CVE Program
- CVE-2026-84151 · NVD
- FIRST EPSS
- GHSA-93v8-jc63-2mm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences