Composer: Perforce source URL permits P4PORT `rsh:` command execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.
Summary
Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and 2.10.3, a malicious dependency package from a custom Composer repository or an untrusted composer.lock file could set source.type to perforce and source.url to an rsh: or jsh: P4PORT value. When the Perforce p4 client was installed and Composer installed the package from source through composer install or composer update, including --prefer-source, Composer\Util\Perforce passed the address to p4 without validation, causing p4 to run a local command with the privileges of the user or CI account. Packagist.org does not permit Perforce source metadata. This issue is fixed in versions 2.2.30 and 2.10.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| composer | composer | 1.0 to before 2.2.30; 2.3.0 to before 2.10.3 | 2.2.30, 2.10.3 | Patch available | CNA |
| — | composer/composer (Packagist) | 2.3.0 to before 2.10.3 | 2.10.3 | Patch available | GHSA-rvx4-ffvw-m9q3 |
| — | composer/composer (Packagist) | 1.0 to before 2.2.30 | 2.2.30 | Patch available | GHSA-rvx4-ffvw-m9q3 |
- composer Vendorcomposer Affected 1.0 to before 2.2.30; 2.3.0 to before 2.10.3 Fixed in 2.2.30, 2.10.3 Patch available CNA
- composer/composer (Packagist) Vendor— Affected 2.3.0 to before 2.10.3 Fixed in 2.10.3 Patch available GHSA-rvx4-ffvw-m9q3
- composer/composer (Packagist) Vendor— Affected 1.0 to before 2.2.30 Fixed in 2.2.30 Patch available GHSA-rvx4-ffvw-m9q3
Remediation
- Fix · CNA composer (composer) Fixed in 2.2.30, 2.10.3
- Fix · GHSA-rvx4-ffvw-m9q3 composer/composer (Packagist) Fixed in 2.10.3 Advisory →
- Fix · GHSA-rvx4-ffvw-m9q3 composer/composer (Packagist) Fixed in 2.2.30 Advisory →
Red Hat 1 advisory
- RHSA-2026:63151 Released 2026-09-03 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images composer-2.10.3-1.hum1@noarch@public-hummingbird-aarch64-rpms, composer-2.10.3-1.hum1@noarch@public-hummingbird-x86_64-rpms, composer-2.10.3-1.hum1@src
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Hardened Images | Fixed | RHSA-2026:63151 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-84361
- 2026-10-03 Alias added: GHSA-rvx4-ffvw-m9q3
References
Other 6
- https://github.com/composer/composer/security/advisories/GHSA-rvx4-ffvw-m9q3
- https://github.com/composer/composer/commit/0aac50528e83ed635cf788333635897469440220
- https://github.com/composer/composer/commit/199ad81a9cc6a2a5164ad79a8da26b2e19e521af
- https://github.com/composer/composer/releases/tag/2.10.3
- https://github.com/composer/composer/releases/tag/2.2.30
- https://github.com/composer/composer
More composer vulnerabilities
- TI-2015-06892 Composer before 2016-02-10 allows cache poisoning from other projects built on the same… CVSS 3.1HIGH 8.8
- TI-2021-17955 Command injection in composer on Windows CVSS 3.1CRITICAL 9.8
- TI-2024-23311 Composer vulnerable to command injection via malicious git/hg branch names CVSS 3.1HIGH 8.8
- TI-2021-10185 Code injection in composer CVSS 3.1HIGH 8.8
- TI-2022-08641 Missing input validation can lead to command execution in composer CVSS 3.1HIGH 8.8
- TI-2026-29055 Composer has Command Injection via Malicious Perforce Reference CVSS 3.1HIGH 8.8
Sources
- CVE-2026-84361 · CVE Program
- CVE-2026-84361 · NVD
- FIRST EPSS
- GHSA-rvx4-ffvw-m9q3 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-84361 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences