Optimole < 4.2.12 - Unauthenticated Stored XSS via Srcset Descriptor Parameter
Priority MEDIUM 41CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Optimole WordPress plugin before 4.2.12 does not properly escape a user supplied value before using it to build an image tag attribute, allowing unauthenticated users to inject arbitrary attributes into pages served to every visitor, which leads to Stored Cross-Site Scripting.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00505 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Optimole (Unknown): 4.2.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Optimole | 4.2.3 to before 4.2.12 | 4.2.12 | Patch available | CNA |
- Optimole VendorUnknown Affected 4.2.3 to before 4.2.12 Fixed in 4.2.12 Patch available CNA
Remediation
- Fix · CNA Optimole (Unknown) Fixed in 4.2.12
Timeline
- 2026-10-02 Threatist record created from CVE-2026-84829
- 2026-10-03 Alias added: GHSA-mwqj-x4rq-9232
References
Sources
- CVE-2026-84829 · CVE Program
- CVE-2026-84829 · NVD
- FIRST EPSS
- GHSA-mwqj-x4rq-9232 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences