EmbedPress < 4.6.7 - Contributor+ Stored XSS via Instagram Carousel Block Attributes
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The EmbedPress WordPress plugin before 4.6.7 does not escape one of its block attributes before outputting it inside an HTML attribute, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks against higher privileged users viewing the post.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00262 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed EmbedPress (Unknown): 4.6.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | EmbedPress | before 4.6.7 | 4.6.7 | Patch available | CNA |
- EmbedPress VendorUnknown Affected before 4.6.7 Fixed in 4.6.7 Patch available CNA
Remediation
- Fix · CNA EmbedPress (Unknown) Fixed in 4.6.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-85002
- 2026-10-03 Alias added: GHSA-ch5r-8r2c-893j
References
Sources
- CVE-2026-85002 · CVE Program
- CVE-2026-85002 · NVD
- FIRST EPSS
- GHSA-ch5r-8r2c-893j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences