Unlimited Elements For Elementor < 2.0.20 - Subscriber+ PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The Unlimited Elements For Elementor WordPress plugin before 2.0.20 does not perform a capability check on an AJAX action and deserializes attacker-controlled stored data through it, which makes it possible for authenticated attackers with subscriber-level access to inject arbitrary PHP objects. A partial fix in the 2.0.18 to 2.0.19 releases raised the privilege required to reach the vulnerable action to editor-level, and the issue was fully resolved in 2.0.20.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Unlimited Elements For Elementor | before 2.0.20 | 2.0.20 | Patch available | CNA |
- Unlimited Elements For Elementor VendorUnknown Affected before 2.0.20 Fixed in 2.0.20 Patch available CNA
Remediation
- Fix · CNA Unlimited Elements For Elementor (Unknown) Fixed in 2.0.20
Timeline
- 2026-10-02 Threatist record created from CVE-2026-85017
- 2026-10-03 Alias added: GHSA-3wpx-h7q2-mv8g
References
Sources
- CVE-2026-85017 · CVE Program
- CVE-2026-85017 · NVD
- FIRST EPSS
- GHSA-3wpx-h7q2-mv8g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences