SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-266 and CWE-285.
Summary
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SpecterOps | BloodHound | 9.0.0; 9.1.0; 9.2.2; 9.4.0; 9.5.0; 9.5.1 | 9.6.0-rc1, 9.6.0, 9.7.0-rc3 | Patch available | CNA |
- BloodHound VendorSpecterOps Affected 9.0.0; 9.1.0; 9.2.2; 9.4.0; 9.5.0; 9.5.1 Fixed in 9.6.0-rc1, 9.6.0, 9.7.0-rc3 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:specterops:bloodhound:*:*:*:*:*:*:*:* | — | — | SpecterOps |
- cpe:2.3:a:specterops:bloodhound:*:*:*:*:*:*:*:* Versions — — ·SpecterOps
Remediation
- Fix · CNA BloodHound (SpecterOps) Fixed in 9.6.0-rc1, 9.6.0, 9.7.0-rc3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-85241
- 2026-10-03 Alias added: GHSA-x4wv-m72p-pcf5
References
More SpecterOps vulnerabilities
- TI-2026-42395 BloodHound Missing Authorization on Custom Node Management API CVSS 4.0HIGH 7.1
Sources
- CVE-2026-85241 · CVE Program
- CVE-2026-85241 · NVD
- FIRST EPSS
- GHSA-x4wv-m72p-pcf5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences