Hostinger Reach 1.0.6 - 1.8.2 - Contributor+ Stored XSS via formId Elementor Widget Attribute
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Hostinger Reach WordPress plugin before 1.8.3 does not sanitize and escape a widget setting before outputting it in the editor preview, allowing users with contributor-level access and above to inject arbitrary web scripts that will execute in the session of a higher-privileged user who opens the affected content in the editor.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Hostinger Reach | 1.0.6 to before 1.8.3 | 1.8.3 | Patch available | CNA |
- Hostinger Reach VendorUnknown Affected 1.0.6 to before 1.8.3 Fixed in 1.8.3 Patch available CNA
Remediation
- Fix · CNA Hostinger Reach (Unknown) Fixed in 1.8.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-87777
- 2026-10-03 Alias added: GHSA-x4pj-54cm-wrgc
References
Sources
- CVE-2026-87777 · CVE Program
- CVE-2026-87777 · NVD
- FIRST EPSS
- GHSA-x4pj-54cm-wrgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences