Vayu X < 1.0.6 - Subscriber+ Arbitrary WordPress.org Plugin Installation and Activation
Priority LOW 31CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-284.
Summary
The Vayu X WordPress theme before 1.0.6 does not perform any capability check on one of its AJAX actions and exposes the nonce guarding it to every logged-in user, allowing any authenticated user, such as a subscriber, to install and activate any hosted on the WordPress.org repository.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00195 9th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Vayu X (Unknown): 1.0.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Vayu X | before 1.0.6 | 1.0.6 | Patch available | CNA |
- Vayu X VendorUnknown Affected before 1.0.6 Fixed in 1.0.6 Patch available CNA
Remediation
- Fix · CNA Vayu X (Unknown) Fixed in 1.0.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-88797
- 2026-10-03 Alias added: GHSA-hfr5-224q-hqxr
References
Sources
- CVE-2026-88797 · CVE Program
- CVE-2026-88797 · NVD
- FIRST EPSS
- GHSA-hfr5-224q-hqxr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences