Unauthenticated update of public UI settings leading to stored cross-site scripting in Rancher
Priority MEDIUM 45CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An unauthenticated update of public UI settings could be used by remote attackers to execute a stored cross-site scripting attack in the Rancher UI, in SUSE Rancher 2.15 before 2.15.2, 2.14 before 2.14.6, 2.13 before 2.13.10, 2.12 before 2.12.14 and 2.11 before 2.11.18.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01036 64th percentileScored 2026-11-07
Fix Fixed Rancher (SUSE): 2.15.2, 2.14.6, 2.13.10 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | Rancher | 2.15.0 to before 2.15.2; 2.14.0 to before 2.14.6; 2.13.0 to before 2.13.10; 2.12.0 to before 2.12.14; 2.11.0se to before 2.11.18 | 2.15.2, 2.14.6, 2.13.10, 2.12.14, 2.11.18 | Patch available | CNA |
- Rancher VendorSUSE Affected 2.15.0 to before 2.15.2; 2.14.0 to before 2.14.6; 2.13.0 to before 2.13.10; 2.12.0 to before 2.12.14; 2.11.0se to before 2.11.18 Fixed in 2.15.2, 2.14.6, 2.13.10, 2.12.14, 2.11.18 Patch available CNA
Remediation
- Fix · CNA Rancher (SUSE) Fixed in 2.15.2, 2.14.6, 2.13.10, 2.12.14, 2.11.18
Timeline
- 2026-10-02 Threatist record created from CVE-2026-88804
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences