Froxlor before 2.3.7 Authorization Bypass via Mysqls.add API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
Froxlor before 2.3.7 fails to validate the mysql_server parameter against a customer's allowed_mysqlserver allowlist in the Mysqls.add API command. Attackers can supply a disallowed server index to create MySQL databases and users on forbidden servers, bypassing per-customer access controls.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA froxlor (froxlor) Fixed in 2.3.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
froxlor 2.3.7
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2026-61800 Froxlor before 2.3.7 Information Disclosure via customer_email.phpPriority MEDIUM 57
Timeline
- 2026-10-02 Threatist record created from CVE-2026-90935
- 2026-10-03 Alias added: GHSA-w63q-47vh-4f98
References
More froxlor vulnerabilities
- TI-2023-00300 Command Injection in froxlor/froxlor CVSS 3.1HIGH 8.8
- TI-2023-02973 Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor CVSS 3.1CRITICAL 9.8
- TI-2023-01234 Authentication Bypass by Primary Weakness in froxlor/froxlor CVSS 3.1CRITICAL 9.8
- TI-2023-01911 Unrestricted Upload of File with Dangerous Type in froxlor/froxlor CVSS 3.1HIGH 8.8
- TI-2026-64867 froxlor before 2.3.12 Authentication Bypass via Session Persistence CVSS 4.0HIGH 8.7
- TI-2026-76945 Symlink following in Froxlor enables root privilege escalation CVSS 4.0CRITICAL 9.4
Sources
- CVE-2026-90935 · CVE Program
- CVE-2026-90935 · NVD
- FIRST EPSS
- GHSA-w63q-47vh-4f98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences