Discourse: Wildcard iframe origin allowlist bypass via authority separators
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-346.
Summary
Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, sites using wildcard patterns in the allowed_iframes setting could accept a crafted iframe URL whose allowlisted suffix appeared after a URL authority separator. The wildcard origin check matched the allowed domain text, while browser URL parsing selected a different attacker-controlled origin. A user with posting privileges could exploit the flaw through a post or a Onebox oEmbed response and cause an attacker-controlled iframe to be rendered independently of the allowlisted domain. Successful exploitation requires a site-configured wildcard iframe pattern and the ability to create a post or trigger an oEmbed request for an attacker-controlled URL. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | before 2026.8.0; 2026.7.0-latest to before 2026.7.2; 2026.6.0-latest to before 2026.6.3; 2026.1.0-latest to before 2026.1.8 | 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8 | Patch available | CNA |
- discourse Vendordiscourse Affected before 2026.8.0; 2026.7.0-latest to before 2026.7.2; 2026.6.0-latest to before 2026.6.3; 2026.1.0-latest to before 2026.1.8 Fixed in 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8 Patch available CNA
Remediation
- Fix · CNA discourse (discourse) Fixed in 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2026-91132
References
Other 6
- https://github.com/discourse/discourse/security/advisories/GHSA-4q3q-hph3-3rvp
- https://github.com/discourse/discourse/pull/42882
- https://github.com/discourse/discourse/commit/80968704c1acb1d2ea2c6011dbf6c02ff13238e5
- https://github.com/discourse/discourse/commit/d5ae0940707f95da5bc4562f7b544243e3103f8a
- https://github.com/discourse/discourse/commit/d88e02ceb2eede4d8b851d9fe8aef753f3aa40b9
- https://github.com/discourse/discourse/commit/db8064f2a2a2a3feb3308a1c932ac61d950c9e56
More discourse vulnerabilities
- TI-2022-22806 Discourse BBCode plugin vulnerable to arbitrary CSS injection CVSS 3.1CRITICAL 9.8
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2022-18730 Discourse Patreon vulnerable to improper validation of email during Patreon authentication CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences