Discourse: Block post iframes whose encoded userinfo bypasses the allowed_iframes allowlist
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Discourse is an open-source discussion platform. Prior to 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0, the Discourse post sanitizer allowed a stored cross-origin iframe to bypass the allowed_iframes prefix policy when the iframe src contained encoded userinfo. The sanitizer validated a decoded form differently from the stored iframe src, allowing the browser to interpret an attacker-controlled host while the allowlist check accepted the encoded URL as an allowed prefix. An authenticated user with posting privileges could persist the iframe in a post and cause attacker-controlled cross-origin content to be rendered. This issue is fixed in versions 2026.1.8, 2026.6.3, 2026.7.2, and 2026.8.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | before 2026.8.0; 2026.7.0-latest to before 2026.7.2; 2026.6.0-latest to before 2026.6.3; 2026.1.0-latest to before 2026.1.8 | 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8 | Patch available | CNA |
- discourse Vendordiscourse Affected before 2026.8.0; 2026.7.0-latest to before 2026.7.2; 2026.6.0-latest to before 2026.6.3; 2026.1.0-latest to before 2026.1.8 Fixed in 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8 Patch available CNA
Remediation
- Fix · CNA discourse (discourse) Fixed in 2026.8.0, 2026.7.2, 2026.6.3, 2026.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2026-91134
References
Other 6
- https://github.com/discourse/discourse/security/advisories/GHSA-54vw-chv3-wjpv
- https://github.com/discourse/discourse/pull/42882
- https://github.com/discourse/discourse/commit/0a8015e6c7a5079981843721494d30c9a91f5415
- https://github.com/discourse/discourse/commit/1304b0c04f87534053b0d574ae5a9b9ba13dd590
- https://github.com/discourse/discourse/commit/bac7dd1201911851462483271b4567246fa1309d
- https://github.com/discourse/discourse/commit/fed3a58c48412ce7207b72a4629ddbc44482cd64
More discourse vulnerabilities
- TI-2022-22806 Discourse BBCode plugin vulnerable to arbitrary CSS injection CVSS 3.1CRITICAL 9.8
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2022-18730 Discourse Patreon vulnerable to improper validation of email during Patreon authentication CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences