MgoSync 2.1.5 - 2.1.6 - Unauthenticated WooCommerce API Credential Disclosure
Priority LOW 39CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
The MgoSync WordPress plugin before 2.1.7 does not have authorization controls on one of its REST API endpoints, allowing unauthenticated users to retrieve the stored WooCommerce API credentials, including a read/write consumer key and secret, from a configured site.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00434 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed MgoSync (Unknown): 2.1.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MgoSync | 2.1.5 to before 2.1.7 | 2.1.7 | Patch available | CNA |
- MgoSync VendorUnknown Affected 2.1.5 to before 2.1.7 Fixed in 2.1.7 Patch available CNA
Remediation
- Fix · CNA MgoSync (Unknown) Fixed in 2.1.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-92404
- 2026-10-03 Alias added: GHSA-3j79-gfcw-gr26
References
Sources
- CVE-2026-92404 · CVE Program
- CVE-2026-92404 · NVD
- FIRST EPSS
- GHSA-3j79-gfcw-gr26 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences