Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.6 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under a race condition, the MCP search tool's shared state handling could have caused search results to be returned under an incorrect user context.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 18.6 to before 19.2.7; 19.3 to before 19.3.3; 19.4 to before 19.4.1 | 19.2.7, 19.3.3, 19.4.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 18.6 to before 19.2.7; 19.3 to before 19.3.3; 19.4 to before 19.4.1 Fixed in 19.2.7, 19.3.3, 19.4.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.6.0 to before 19.2.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.6.0 to before 19.2.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.3.0 to before 19.3.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.3.0 to before 19.3.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.4.0:*:*:*:community:*:*:* | 19.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.4.0:*:*:*:enterprise:*:*:* | 19.4.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.6.0 to before 19.2.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.6.0 to before 19.2.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.3.0 to before 19.3.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.3.0 to before 19.3.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.4.0:*:*:*:community:*:*:* Versions 19.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.4.0:*:*:*:enterprise:*:*:* Versions 19.4.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 19.2.7, 19.3.3, 19.4.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.2.7, 19.3.3, 19.4.1
7 records Highest priority Priority MEDIUM 2 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2026-63046 Integer Overflow or Wraparound in GitLabPriority MEDIUM 44
- TI-2026-60363 Double Free in GitLabPriority MEDIUM 43
- TI-2026-62356 Missing Authorization in GitLabPriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2026-92628
- 2026-10-03 Alias added: GHSA-vp7f-562j-4qgr
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-92628 · CVE Program
- CVE-2026-92628 · NVD
- FIRST EPSS
- GHSA-vp7f-562j-4qgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences