Payload CMS storage-vercel-blob Adapter Improper Access Control on Upload Route
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
The @payloadcms/storage-vercel-blob storage adapter for Payload contains an improper access control vulnerability that allows authenticated users to bypass collection-level permissions by accessing the client-upload route directly. Attackers can upload files through the client-upload endpoint without possessing the required collection access permissions, circumventing the intended access control enforcement.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| payloadcms | payload | 3.25.0 to before 3.90.0; 4.0.0-canary.0 to before 4.0.0-canary.34 | 3.90.0, 4.0.0-canary.34 | Patch available | CNA |
| — | @payloadcms/storage-vercel-blob (npm) | 3.25.0 to before 3.90.0 | 3.90.0 | Patch available | GHSA-mc8m-rr6c-r5qr |
| — | @payloadcms/storage-vercel-blob (npm) | 4.0.0-canary.0 to before 4.0.0-canary.34 | 4.0.0-canary.34 | Patch available | GHSA-mc8m-rr6c-r5qr |
- payload Vendorpayloadcms Affected 3.25.0 to before 3.90.0; 4.0.0-canary.0 to before 4.0.0-canary.34 Fixed in 3.90.0, 4.0.0-canary.34 Patch available CNA
- @payloadcms/storage-vercel-blob (npm) Vendor— Affected 3.25.0 to before 3.90.0 Fixed in 3.90.0 Patch available GHSA-mc8m-rr6c-r5qr
- @payloadcms/storage-vercel-blob (npm) Vendor— Affected 4.0.0-canary.0 to before 4.0.0-canary.34 Fixed in 4.0.0-canary.34 Patch available GHSA-mc8m-rr6c-r5qr
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:payloadcms:payload:*:*:*:*:*:*:*:* | — | — | payloadcms |
- cpe:2.3:a:payloadcms:payload:*:*:*:*:*:*:*:* Versions — — ·payloadcms
Remediation
- Fix · CNA payload (payloadcms) Fixed in 3.90.0, 4.0.0-canary.34
- Fix · GHSA-mc8m-rr6c-r5qr @payloadcms/storage-vercel-blob (npm) Fixed in 3.90.0 Advisory →
- Fix · GHSA-mc8m-rr6c-r5qr @payloadcms/storage-vercel-blob (npm) Fixed in 4.0.0-canary.34 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-93363
- 2026-11-04 Alias added: GHSA-mc8m-rr6c-r5qr
- 2026-11-04 Fix available: npm/@payloadcms/[email protected], npm/@payloadcms/[email protected] · GHSA-mc8m-rr6c-r5qr
- 2026-11-04 CVSS score added · GHSA-mc8m-rr6c-r5qr
- 2026-11-04 Weakness changed · GHSA-mc8m-rr6c-r5qr
- 2026-11-04 5 new references · GHSA-mc8m-rr6c-r5qr
References
More payloadcms vulnerabilities
- TI-2026-10166 PayloadCMS 3.84.1 - Authenticated account lockout bypass through default unlock access CVSS 4.0MEDIUM 5.3
- TI-2026-20653 Payload has an SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters CVSS 3.1CRITICAL 9.8
- TI-2026-68608 Payload CMS lets attackers update collection documents CVSS 3.1CRITICAL 9.8
- TI-2026-68606 Remote code execution in Payload Form Builder plugin CVSS 3.1CRITICAL 10.0
- TI-2026-68480 SQL injection in Payload SQLite and Postgres adapters CVSS 3.1CRITICAL 9.8
- TI-2026-68479 Prototype pollution in Payload Import Export plugin CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-93363 · CVE Program
- CVE-2026-93363 · NVD
- FIRST EPSS
- GHSA-mc8m-rr6c-r5qr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences