Read the docs
TI-2026-63470 Aliases CVE-2026-94588GHSA-mpx3-wp2c-xm4m

In Proxmox pmg-api, an argument injection vulnerability exists in the package changelog…

Priority LOW 20CWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-88.

Summary

In Proxmox pmg-api, an argument injection vulnerability exists in the package changelog retrieval functionality. This is caused by improper handling of user-supplied input passed to the underlying apt-get command when fetching package changelogs. It requires authentication but can be exploited in a CSRF-style attack.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00247 16th percentileScored 2026-11-07
Fix Fixed pmg-api (Proxmox): 9.0.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Proxmoxpmg-api9.0.0 to before 9.0.39.0.3Patch availableCNA
  • pmg-api VendorProxmox Affected 9.0.0 to before 9.0.3 Fixed in 9.0.3 Patch available CNA

Remediation

  • Fix · CNA pmg-api (Proxmox) Fixed in 9.0.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-94588
  2. 2026-10-03 Alias added: GHSA-mpx3-wp2c-xm4m

References

  • TI-2022-16050 Proxmox Virtual Environment (PVE) and Proxmox Mail Gateway (PMG) are vulnerable to SSRF… CVSS 3.1CRITICAL 9.8
  • TI-2022-13353 A reflected cross-site scripting (XSS) vulnerability in Proxmox Virtual Environment prior… CVSS 3.1CRITICAL 9.0
  • TI-2022-16049 A response-header CRLF injection vulnerability in the Proxmox Virtual Environment (PVE)… CVSS 3.1HIGH 7.1
  • TI-2025-35562 A stored cross-site scripting (XSS) vulnerability exists in the WebAuthn Relying Party… CVSS 3.1MEDIUM 5.4
  • TI-2025-35561 A stored cross-site scripting (XSS) vulnerability in the U2F Origin field of the… CVSS 3.1MEDIUM 5.4
  • TI-2025-35560 A stored cross-site scripting (XSS) vulnerability in the HTTP Proxy field within the… CVSS 3.1MEDIUM 5.4
See all 14 →

Sources