AT_SECURE program buffer overflow via $ORIGIN processing
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 4 fixed, 6 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA glibc (The GNU C Library) Fixed in 2.45
Red Hat 2 advisories
- RHSA-2026:95618 Released 2026-11-05 · Red Hat rating Moderateglibc security update
- Red Hat Enterprise Linux AppStream (v. 9) glibc-devel-2.34-284.el9_8.4, glibc-doc-2.34-284.el9_8.4, glibc-headers-2.34-284.el9_8.4 +2
- Red Hat Enterprise Linux BaseOS (v. 9) glibc-2.34-284.el9_8.4, glibc-all-langpacks-2.34-284.el9_8.4, glibc-common-2.34-284.el9_8.4 +47
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) glibc-benchtests-2.34-284.el9_8.4, glibc-nss-devel-2.34-284.el9_8.4, glibc-static-2.34-284.el9_8.4 +2
- RHSA-2026:72503 Released 2026-09-28 · Red Hat rating ModerateRed Hat Hardened Images RPMs Security Update
- Red Hat Hardened Images compat-libpthread-nonshared-2.43-8.7.hum1@aarch64, compat-libpthread-nonshared-2.43-8.7.hum1@x86_64, glibc-2.43-8.7.hum1@aarch64 +47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
The GNU C Library glibc 2.45
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-59353 AT_SECURE programs may load attacker-controlled code via $ORIGINPriority LOW 29
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat OpenShift AI (RHOAI) | Affected | — |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 5 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:95618 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2026:95618 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2026:95618 |
| Red Hat Hardened Images | Fixed | RHSA-2026:72503 |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-02 Threatist record created from CVE-2026-95818
- 2026-10-03 Alias added: GHSA-h8x4-734c-9753
- 2026-10-30 Affected versions changed · Red Hat
- 2026-11-06 Fix available: Red Hat Enterprise Linux AppStream (v. 9), Red Hat Enterprise Linux BaseOS (v. 9), Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) · Red Hat
- 2026-11-06 Fix available: RHSA-2026:95618 · Red Hat
- 2026-11-06 Affected versions changed · Red Hat
References
More GNU vulnerabilities
- TI-2026-19388 telnetd in GNU Inetutils through 2.7 allows remote authentication bypass via a "-f root"… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05164 GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the… KEVCVSS 3.1HIGH 8.8
- TI-2023-04522 Glibc: buffer overflow in ld.so leading to privilege escalation KEVCVSS 3.1HIGH 7.8
- TI-2009-03392 The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-95818 · CVE Program
- CVE-2026-95818 · NVD
- FIRST EPSS
- GHSA-h8x4-734c-9753 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-95818 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences