MCP Server for WordPress < 1.8.2 - Administrator Account Creation via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The MCP Server for WordPress WordPress plugin before 1.8.2 does not correctly verify the WordPress REST API nonce for cookie-authenticated requests when a condition an attacker can influence is present, allowing unauthenticated attackers to perform administrator-only actions, including creating a new administrator account, by tricking a logged-in administrator into visiting a crafted page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MCP Server for WordPress | before 1.8.2 | 1.8.2 | Patch available | CNA |
- MCP Server for WordPress VendorUnknown Affected before 1.8.2 Fixed in 1.8.2 Patch available CNA
Remediation
- Fix · CNA MCP Server for WordPress (Unknown) Fixed in 1.8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MCP Server for WordPress 1.8.2
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-63795 MCP Server for WordPress < 1.8.2 - Contributor+ Arbitrary Post Title Disclosure via workflows/run REST RoutePriority LOW 13
- TI-2026-63794 MCP Server for WordPress < 1.8.2 - Contributor+ Workflow Modification and Deletion via Missing Ownership CheckPriority LOW 13
Timeline
- 2026-10-02 Threatist record created from CVE-2026-96524
- 2026-10-03 Alias added: GHSA-9frx-mgw6-jh42
References
Sources
- CVE-2026-96524 · CVE Program
- CVE-2026-96524 · NVD
- FIRST EPSS
- GHSA-9frx-mgw6-jh42 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences