Path traversal in Netgate pfSense Plus
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In Netgate pfSense Plus before 26.07 and pfSense CE before 2.9.0, a Local File Inclusion (LFI) vulnerability in the Dashboard (index.php) widget sequence data handling allows an authenticated attacker to execute arbitrary PHP code. To exploit this, an attacker with privileges to modify Dashboard settings and write arbitrary files to the pfSense firewall system (e.g., /tmp/test.widget.php) can submit a crafted widget sequence value containing a path traversal payload (e.g., ../../../../../../../../../../../tmp/test). The Dashboard will subsequently read and execute the arbitrary PHP file as if it were a standard widget.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA pfSense Plus (Netgate) Fixed in 26.07
- Fix · CNA pfSense CE (Netgate) Fixed in 2.9.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-97730
- 2026-10-03 Alias added: GHSA-pc4f-6357-r2v6
References
More Netgate vulnerabilities
- TI-2022-13704 pfSense pfBlockerNG through 2.1.4_26 allows remote attackers to execute arbitrary OS… CVSS 3.1CRITICAL 9.8
- TI-2023-12003 A command injection vulnerability in the function restore_rrddata() of Netgate pfSense… CVSS 3.1HIGH 8.8
- TI-2024-31010 A cross-site scripting (XSS) vulnerability in pfsense v2.5.2 allows attackers to execute… CVSS 3.1CRITICAL 9.3
- TI-2023-11923 Improper restriction of excessive authentication attempts in the SSHGuard component of… CVSS 3.1CRITICAL 9.8
- TI-2023-26046 An issue in Netgate pfSense Plus v.23.05.1 and before and pfSense CE v.2.7.0 allows a… CVSS 3.1HIGH 8.8
- TI-2023-22567 An issue in Netgate pfSense v.2.7.0 allows a remote attacker to execute arbitrary code… CVSS 3.1HIGH 8.8
Sources
- CVE-2026-97730 · CVE Program
- CVE-2026-97730 · NVD
- FIRST EPSS
- GHSA-pc4f-6357-r2v6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences