Read the docs

Stored XSS in WikiSEO author and image properties on action=info

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - WikiSEO Extension allows Stored XSS. This issue affects Mediawiki - WikiSEO Extension: from * before 1.46.1, 1.45.5, 1.43.10.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00155 4th percentileScored 2026-11-07
Fix Fixed Mediawiki - WikiSEO Extension (Wikimedia Foundation): 1.46.1, 1.45.5, 1.43.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediawiki - WikiSEO Extensionbefore 1.46.1, 1.45.5, 1.43.101.46.1, 1.45.5, 1.43.10Patch availableCNA
  • Mediawiki - WikiSEO Extension VendorWikimedia Foundation Affected before 1.46.1, 1.45.5, 1.43.10 Fixed in 1.46.1, 1.45.5, 1.43.10 Patch available CNA

Remediation

  • Fix · CNA Mediawiki - WikiSEO Extension (Wikimedia Foundation) Fixed in 1.46.1, 1.45.5, 1.43.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-100243
  2. 2026-10-03 Alias added: GHSA-rvcr-fqrj-f6pf

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources