Unauthenticated remote code execution through wikitext in ExternalData
Priority MEDIUM 51CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Wikimedia Foundation Mediawiki - ExternalData Extension allows OS Command Injection. This issue affects Mediawiki - ExternalData Extension: from * before 3.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01214 68th percentileScored 2026-11-07
Fix Fixed Mediawiki - ExternalData Extension (Wikimedia Foundation): 3.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | Mediawiki - ExternalData Extension | before 3.7 | 3.7 | Patch available | CNA |
- Mediawiki - ExternalData Extension VendorWikimedia Foundation Affected before 3.7 Fixed in 3.7 Patch available CNA
Remediation
- Fix · CNA Mediawiki - ExternalData Extension (Wikimedia Foundation) Fixed in 3.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-100382
- 2026-10-03 Alias added: GHSA-vwh3-jq98-4w28
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-100382 · CVE Program
- CVE-2026-100382 · NVD
- FIRST EPSS
- GHSA-vwh3-jq98-4w28 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences