coollabsio Coolify Route-Level Middleware CanUpdateResource.php authorization
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
A flaw has been found in coollabsio Coolify up to 4.1.2. The affected element is an unknown function of the file app/Http/Middleware/CanUpdateResource.php of the component Route-Level Middleware. Executing a manipulation can lead to missing authorization. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 4.2.0 is sufficient to fix this issue. This patch is called 39ae16de4248075de8c08f3259114e064b20d52d. It is advisable to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| coollabsio | Coolify | 4.1.0; 4.1.1; 4.1.2 | 4.2.0 | Patch available | CNA |
- Coolify Vendorcoollabsio Affected 4.1.0; 4.1.1; 4.1.2 Fixed in 4.2.0 Patch available CNA
CPE names CNA · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:coollabsio:coolify:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:coollabsio:coolify:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · CNA Coolify (coollabsio) Fixed in 4.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-100744
- 2026-10-03 Alias added: GHSA-wv46-wr7m-42rh
References
Patch 3
More coollabsio vulnerabilities
- TI-2025-40716 Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in File Storage Directory Mount Path CVSS 4.0CRITICAL 9.4
- TI-2025-40715 Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in Dynamic Proxy Configuration Filename CVSS 4.0CRITICAL 9.4
- TI-2025-40714 Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in PostgreSQL Init Script Filename CVSS 4.0CRITICAL 9.4
- TI-2025-40713 Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in Database Import CVSS 4.0CRITICAL 9.4
- TI-2025-40712 Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in Database Backup CVSS 3.1CRITICAL 10.0
- TI-2025-16498 Coolify Vulnerable to Private Key Enumeration on Onboarding resulting in Remote Command Execution (RCE) CVSS 3.1CRITICAL 10.0
Sources
- CVE-2026-100744 · CVE Program
- CVE-2026-100744 · NVD
- FIRST EPSS
- GHSA-wv46-wr7m-42rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences