Krayin laravel-crm attachment-download Endpoint acl.php resource injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A vulnerability has been found in Krayin laravel-crm up to 2.2.5. The impacted element is the function Storage::download of the file packages/Webkul/Admin/src/Config/acl.php of the component attachment-download Endpoint. The manipulation of the argument ID leads to improper control of resource identifiers. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.2.6 is sufficient to resolve this issue. The identifier of the patch is 13d6988cda8d69ece45ee1890effc90a7f21cdc1. It is suggested to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA laravel-crm (Krayin) Fixed in 2.2.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-100884
- 2026-10-03 Alias added: GHSA-gxmj-vr4j-8j5c
References
Patch 3
More krayin vulnerabilities
- TI-2026-30041 Krayin CRM 2.2.4 Missing Authentication via install/api/admin-config-setup CVSS 4.0CRITICAL 9.3
- TI-2026-61808 Krayin CRM through 2.2.6 Unauthenticated Email Injection via inbound-parse CVSS 4.0HIGH 8.8
- TI-2026-44065 Krayin CRM Insecure Direct Object Reference via Controllers CVSS 4.0HIGH 8.7
- TI-2026-30042 Krayin CRM < 2.2.4 Blind SQL Injection via LeadDataGrid.php rotten_lead Parameter CVSS 4.0HIGH 8.7
- TI-2026-65023 Krayin laravel-crm admin-config-setup API Endpoint CanInstall.php authorization CVSS 4.0MEDIUM 6.9
- TI-2026-64295 krayin laravel-crm Upload Functionality ConfigurationForm.php rules cross site scripting CVSS 4.0MEDIUM 5.1
Sources
- CVE-2026-100884 · CVE Program
- CVE-2026-100884 · NVD
- FIRST EPSS
- GHSA-gxmj-vr4j-8j5c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences