Undisclosed RCE in Zammad v6.3 and higher
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-384.
Summary
Zammad versions 6.3.0 to 6.5.4 are vulnerable a session hijack vulnerability that leads to remote code execution as the zammad user. The bug is also present in version 7.0.0 to version 7.1.2, but not exploitable due to changes in the underlying framework.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zammad GmbH | Zammad | 6.3.0 to before 6.5.4 | 6.5.4 | Patch available | CNA |
- Zammad VendorZammad GmbH Affected 6.3.0 to before 6.5.4 Fixed in 6.5.4 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* | 6.3.0 – 6.5.4 | Vulnerable | Zammad GmbH |
| cpe:2.3:a:docker:docker:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Docker |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
- cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* Versions 6.3.0 – 6.5.4 Vulnerable ·Zammad GmbH
- cpe:2.3:a:docker:docker:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Docker
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
Remediation
- Fix · CNA Zammad (Zammad GmbH) Fixed in 6.5.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Zammad — zammad.com/en/advisories/cve-2026-102489-cve-2026-102490
2 records Highest priority Priority CRITICAL 2 CRITICAL
Other records, highest priority first
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM packagePriority CRITICAL 100
Timeline
- 2026-10-02 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2026-102489
- 2026-10-03 Alias added: GHSA-xmw5-m2wg-4243
- 2026-10-04 EPSS moved to the 50th–90th percentile
- 2026-10-07 Affected versions changed · CNA
- 2026-10-07 2 new references · CNA
- 2026-10-10 CISA SSVC decision points changed
- 2026-10-29 EPSS moved to the 95th–99th percentile
References
More Zammad GmbH Zammad vulnerabilities
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package KEVCVSS 4.0CRITICAL 9.4
- TI-2024-22252 An issue was discovered in Zammad before 6.3.0. CVSS 3.1CRITICAL 9.1
- TI-2022-23785 A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate… CVSS 3.1CRITICAL 9.8
- TI-2021-18599 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2021-18603 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2020-15897 An issue was discovered in Zammad before 3.4.1. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-102489 · CVE Program
- CVE-2026-102489 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-xmw5-m2wg-4243 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences