JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79 and CWE-94.
Summary
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0 until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the Plural-Forms header in a selected third-party language pack can append JavaScript after a valid plural rule because prefix-only regular-expression validation accepts a matching prefix without requiring the entire header to match. JupyterLab passes the accepted expression to new Function, so loading the catalogue and translating a plural string executes the appended code in the authenticated JupyterLab origin. Where Jupyter Server kernels, terminals, and APIs are exposed, the code can use authenticated server APIs to read or modify files and run code. Impact is much more limited in JupyterLite because it typically lacks most exposed Jupyter Server surfaces. The default English locale is unaffected because it does not load a translation catalogue. This issue is fixed in JupyterLab 4.5.11 and 4.6.4 and JupyterLite Core 0.8.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | 3.0.0 to before 4.5.11; 4.6.0 to before 4.6.4 | 4.5.11, 4.6.4 | Patch available | CNA |
| jupyterlab | jupyterlite-core | before 0.8.4 | 0.8.4 | Patch available | CNA |
| — | jupyterlab (PyPI) | 4.6.0 to before 4.6.4 | 4.6.4 | Patch available | GHSA-3jqq-pw4j-pqcj |
| — | jupyterlab (PyPI) | 3.0.0 to before 4.5.11 | 4.5.11 | Patch available | GHSA-3jqq-pw4j-pqcj |
| — | jupyterlite-core (PyPI) | before 0.8.4 | 0.8.4 | Patch available | GHSA-3jqq-pw4j-pqcj |
- jupyterlab Vendorjupyterlab Affected 3.0.0 to before 4.5.11; 4.6.0 to before 4.6.4 Fixed in 4.5.11, 4.6.4 Patch available CNA
- jupyterlite-core Vendorjupyterlab Affected before 0.8.4 Fixed in 0.8.4 Patch available CNA
- jupyterlab (PyPI) Vendor— Affected 4.6.0 to before 4.6.4 Fixed in 4.6.4 Patch available GHSA-3jqq-pw4j-pqcj
- jupyterlab (PyPI) Vendor— Affected 3.0.0 to before 4.5.11 Fixed in 4.5.11 Patch available GHSA-3jqq-pw4j-pqcj
- jupyterlite-core (PyPI) Vendor— Affected before 0.8.4 Fixed in 0.8.4 Patch available GHSA-3jqq-pw4j-pqcj
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | — | — | jupyterlab |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions — — ·jupyterlab
Remediation
- Fix · CNA jupyterlab (jupyterlab) Fixed in 4.5.11, 4.6.4
- Fix · CNA jupyterlite-core (jupyterlab) Fixed in 0.8.4
- Fix · GHSA-3jqq-pw4j-pqcj jupyterlab (PyPI) Fixed in 4.6.4 Advisory →
- Fix · GHSA-3jqq-pw4j-pqcj jupyterlab (PyPI) Fixed in 4.5.11 Advisory →
- Fix · GHSA-3jqq-pw4j-pqcj jupyterlite-core (PyPI) Fixed in 0.8.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Migration Toolkit for Applications 8 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-102830
- 2026-10-03 Alias added: GHSA-3jqq-pw4j-pqcj
References
Other 7
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-3jqq-pw4j-pqcj
- https://github.com/jupyterlab/jupyterlab/commit/985a3223cd77fd4f991cd90066342a90711d70f6
- https://github.com/jupyterlab/jupyterlab/commit/de324ae91346c713c4f5e5485f97b6e914e0f774
- https://github.com/jupyterlab/jupyterlab/commit/f9de43dc565a1118120d466117f877a189a4ce90
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4
- https://github.com/jupyterlab/jupyterlab
More jupyterlab vulnerabilities
- TI-2026-32161 Jupyter Enterprise Gateway Has Kubernetes Manifest Injection via Jinja2 Template Rendering CVSS 4.0CRITICAL 10.0
- TI-2026-32160 Jupyter Enterprise Gateway: Jinja2 Template Server Side Template Injection results in Remote Code Execution CVSS 4.0CRITICAL 10.0
- TI-2026-32159 Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids can be Bypassed CVSS 3.1CRITICAL 9.8
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-78983 Path traversal in nbconvert lets crafted notebooks write files CVSS 4.0HIGH 8.8
- TI-2026-39372 JupyterLab Git: Stored XSS leading to RCE CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-102830 · CVE Program
- CVE-2026-102830 · NVD
- FIRST EPSS
- GHSA-3jqq-pw4j-pqcj · GitHub Advisory Database · CC BY 4.0
- CVE-2026-102830 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences