Ghost from 2.5.0 before 6.64.0 Stored XSS via oEmbed Photo Responses
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Ghost from 2.5.0 before 6.64.0 contains a stored cross-site scripting vulnerability that allows attackers to inject untrusted scripts into post content via oEmbed photo responses. Attackers can host malicious oEmbed photo responses so that embedding their URL stores scripts that run in the Ghost editor, published site, and newsletter emails, compromising staff admin sessions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Ghost (TryGhost) Fixed in 6.64.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
TryGhost Ghost 6.64.0
8 records Highest priority Priority MEDIUM 1 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-66061 Ghost from 6.10.3 before 6.64.0 RCE via Theme Translation FilesPriority MEDIUM 40
- TI-2026-66056 Ghost 5.94.0 before 6.64.0 Stored XSS via Bookmark Card ImagesPriority LOW 38
- TI-2026-66054 Ghost 6.22.1 before 6.64.0 Stored XSS via Local Storage File UploadsPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-104414
- 2026-10-03 Alias added: GHSA-7wpv-mphg-4gmw
References
More TryGhost vulnerabilities
- TI-2026-21459 Ghost has a SQL Injection in its Content API CVSS 3.1CRITICAL 9.4
- TI-2022-10277 An arbitrary file upload vulnerability in the file upload module of Ghost v4.39.0 allows… CVSS 3.1CRITICAL 9.8
- TI-2024-22785 Ghost through 5.85.1 allows remote attackers to bypass an authentication rate-limit… CVSS 3.1CRITICAL 9.1
- TI-2023-14843 Ghost vulnerable to disclosure of private API fields CVSS 3.1HIGH 7.5
- TI-2025-09049 Ghost 6.0.6 - SSRF via oEmbed Bookmark CVSS 4.0MEDIUM 6.1
- TI-2023-20918 Arbitrary file read via symlinks in Ghost CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-104414 · CVE Program
- CVE-2026-104414 · NVD
- FIRST EPSS
- GHSA-7wpv-mphg-4gmw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences