solspace/craft-freeform Exposed to Known Axios Vulnerabilities via Precompiled Assets
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Summary The latest versions of both 4.x and 5.x are using Axios versions < 1.7.5 and as such are subject to known vulnerabilities as per: https://security.snyk.io/package/npm/axios ### Details We've had this flagged up in a pen test, which indicates the issue stems from this script: /freeform/plugin.js. I couldn't see any reference to vulnerable axios versions in your package.json files, but noticed some precompiled files in packages/plugin so I'm assuming those are where the issue lies.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | solspace/craft-freeform (Packagist) | before 4.1.22 | 4.1.22 | Patch available | GHSA-rwr8-xrpw-9qf5 |
| — | solspace/craft-freeform (Packagist) | 5.0.0-beta.1 to before 5.5.9 | 5.5.9 | Patch available | GHSA-rwr8-xrpw-9qf5 |
- solspace/craft-freeform (Packagist) Vendor— Affected before 4.1.22 Fixed in 4.1.22 Patch available GHSA-rwr8-xrpw-9qf5
- solspace/craft-freeform (Packagist) Vendor— Affected 5.0.0-beta.1 to before 5.5.9 Fixed in 5.5.9 Patch available GHSA-rwr8-xrpw-9qf5
Remediation
- Fix · GHSA-rwr8-xrpw-9qf5 solspace/craft-freeform (Packagist) Fixed in 4.1.22 Advisory →
- Fix · GHSA-rwr8-xrpw-9qf5 solspace/craft-freeform (Packagist) Fixed in 5.5.9 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-rwr8-xrpw-9qf5
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences