Read the docs
TI-2026-66189 Aliases GHSA-3v2x-9xcv-2v2v

SurrealDB Affected by Confused Deputy Privilege Escalation through Future Fields and Functions

Priority LOW 38CWE-441Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Unprivileged users (for example, those with the database editor role) can create or modify fields in records that contain functions or `futures`. `Futures` are values which are only computed when the value is queried. The query executes in the context of the querying user, rather than the user who originally defined the future. Likewise, fields containing functions or custom-defined logic (`closures`) are executed under the privileges of the invoking user, not the creator. This results in a confused deputy vulnerability: an attacker with limited privileges can define a malicious function or future field that performs privileged actions. When a higher-privileged user (such as a root owner or namespace administrator) executes the function or queries or modifies that record, the function executes with their elevated permissions. ### Impact An attacker who can create or update function/future fields can plant logic that executes with a privileged user’s context. If a privileged user performs a write that touches the malicious field, the attacker can achieve full privilege escalation (e.g., create a root owner and take over the server). If a privileged user performs a read action on the malicious field, this attack vector could still be potentially be used to perform limited denial of service or, in the specific case where the network capability was explicitly enabled and unrestricted, exfiltrate database information over the network. ### Patches Versions prior to 2.5.0 and 3.0.0-beta.3 are vulnerable. For SurrealDB 3.0, `futures` are no longer supported, replaced by `computed` fields, only available within schemaful tables. Further to this patches for 2.5.0 and 3.0.0-beta.3: - Implements an `auth_limit` on defined apis, functions, fields and events, that limits execution to the permissions of the creating user or the invoking user, whichever is lower. - Prevents `closures` from being stored, that eliminates a potential attack surface. For 2.5.0 this can still be allowed by using the `insecure_storable_closures` capability - Ensures the proper auth level is used to compute expressions in signin & signup **_For existing apis, events, fields and functions defined prior to upgrading to 2.5.0 or 3.0.0-beta.3 `auth_limit` will not apply, to avoid breaking changes. These will need to subsequently be redefined so that `auth_limit` can take effect._** ### Workarounds Users unable to patch are advised to evaluate their use of the database to identify where low privileged users are able to define logic subsequently executed by privileged users, such as apis, functions, futures fields and events, and recommended to minimise these instances. ### References [Futures](https://surrealdb.com/docs/surrealql/datamodel/futures) [Closures](https://surrealdb.com/docs/surrealql/datamodel/closures) [SurrealDB Environment Variables](https://surrealdb.com/docs/surrealdb/cli/env)

Why it matters now

Fix Fixed surrealdb (crates.io): 2.5.0, 3.0.0-beta.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—surrealdb (crates.io)before 2.5.02.5.0Patch availableGHSA-3v2x-9xcv-2v2v
—surrealdb (crates.io)3.0.0-alpha.1 to before 3.0.0-beta.33.0.0-beta.3Patch availableGHSA-3v2x-9xcv-2v2v
  • surrealdb (crates.io) Vendor— Affected before 2.5.0 Fixed in 2.5.0 Patch available GHSA-3v2x-9xcv-2v2v
  • surrealdb (crates.io) Vendor— Affected 3.0.0-alpha.1 to before 3.0.0-beta.3 Fixed in 3.0.0-beta.3 Patch available GHSA-3v2x-9xcv-2v2v

Remediation

  • Fix · GHSA-3v2x-9xcv-2v2v surrealdb (crates.io) Fixed in 2.5.0 Advisory →
  • Fix · GHSA-3v2x-9xcv-2v2v surrealdb (crates.io) Fixed in 3.0.0-beta.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-3v2x-9xcv-2v2v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences