Next.js HTTP request deserialization can lead to DoS when using insecure React Server Components
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400 and CWE-502.
Summary
A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23864](https://github.com/facebook/react/security/advisories/GHSA-83fc-fqcc-2hmg). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 13.0.0 to before 15.0.8 | 15.0.8 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.1.1-canary.0 to before 15.1.12 | 15.1.12 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.2.0-canary.0 to before 15.2.9 | 15.2.9 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.3.0-canary.0 to before 15.3.9 | 15.3.9 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.4.0-canary.0 to before 15.4.11 | 15.4.11 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.5.1-canary.0 to before 15.5.10 | 15.5.10 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 15.6.0-canary.0 to before 15.6.0-canary.61 | 15.6.0-canary.61 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 16.0.0-beta.0 to before 16.0.11 | 16.0.11 | Patch available | GHSA-h25m-26qc-wcjf |
| — | next (npm) | 16.1.0-canary.0 to before 16.1.5 | 16.1.5 | Patch available | GHSA-h25m-26qc-wcjf |
- next (npm) Vendor— Affected 13.0.0 to before 15.0.8 Fixed in 15.0.8 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.1.1-canary.0 to before 15.1.12 Fixed in 15.1.12 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.2.0-canary.0 to before 15.2.9 Fixed in 15.2.9 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.3.0-canary.0 to before 15.3.9 Fixed in 15.3.9 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.4.0-canary.0 to before 15.4.11 Fixed in 15.4.11 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.5.1-canary.0 to before 15.5.10 Fixed in 15.5.10 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 15.6.0-canary.0 to before 15.6.0-canary.61 Fixed in 15.6.0-canary.61 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 16.0.0-beta.0 to before 16.0.11 Fixed in 16.0.11 Patch available GHSA-h25m-26qc-wcjf
- next (npm) Vendor— Affected 16.1.0-canary.0 to before 16.1.5 Fixed in 16.1.5 Patch available GHSA-h25m-26qc-wcjf
Remediation
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.0.8 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.1.12 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.2.9 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.3.9 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.4.11 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.5.10 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 15.6.0-canary.61 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 16.0.11 Advisory →
- Fix · GHSA-h25m-26qc-wcjf next (npm) Fixed in 16.1.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-h25m-26qc-wcjf
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences