amphp/http-server affected by HTTP/2 DDoS vulnerability
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.
Summary
Versions of `amphp/http-server` prior to `3.4.4` for the 3.x release branch and prior to `2.1.10` for the 2.x release branch are vulnerable to the HTTP/2 "MadeYouReset" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506. In versions `3.4.4` and `2.1.10`, stream reset protection has been refactored to account for the number of reset streams within a sliding time window. Note that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | amphp/http-server (Packagist) | 3.0.0-beta.1 to before 3.4.4 | 3.4.4 | Patch available | GHSA-8grv-jq2g-cfhw |
| — | amphp/http-server (Packagist) | 2.0.0-rc1 to before 2.1.10 | 2.1.10 | Patch available | GHSA-8grv-jq2g-cfhw |
- amphp/http-server (Packagist) Vendor— Affected 3.0.0-beta.1 to before 3.4.4 Fixed in 3.4.4 Patch available GHSA-8grv-jq2g-cfhw
- amphp/http-server (Packagist) Vendor— Affected 2.0.0-rc1 to before 2.1.10 Fixed in 2.1.10 Patch available GHSA-8grv-jq2g-cfhw
Remediation
- Fix · GHSA-8grv-jq2g-cfhw amphp/http-server (Packagist) Fixed in 3.4.4 Advisory →
- Fix · GHSA-8grv-jq2g-cfhw amphp/http-server (Packagist) Fixed in 2.1.10 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-8grv-jq2g-cfhw
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences