AWS CLI: cli_history database does not restrict file permissions on Unix systems
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
**Summary** AWS CLI is a command line tool for interacting with AWS services. When the cli_history feature is enabled, the history database file is created with default permissions, potentially allowing other local users on a multi-user system to read the file. **Impact** When cli_history is enabled, AWS CLI stores command history including command parameters and API request/response data in a local SQLite database. On multi-user Unix systems, the default file permissions may allow other local users to read this file, potentially exposing sensitive information. This issue only affects users who have explicitly enabled cli_history, which is disabled by default. **Impacted versions:** 1.13.0 - 1.44.37 (v1), 2.0.0 - 2.33.20 (v2) **Patches** This issue has been addressed in the latest versions 2.33.21 and 1.44.38 of AWS CLI. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. **Workarounds** Users can manually set restrictive permissions on the history database file. Alternatively, disable cli_history by removing `cli_history = enabled` from the AWS config file. **Resources** If there are any questions or comments about this advisory, contact AWS Security via the [vulnerability reporting page](https://aws.amazon.com/security/vulnerability-reporting) or directly via email to [[email protected]](mailto:[email protected]). Please do not create a public GitHub issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | awscli (PyPI) | 1.13.0 to before 1.44.38 | 1.44.38 | Patch available | GHSA-747p-wmpv-9c78 |
- awscli (PyPI) Vendor— Affected 1.13.0 to before 1.44.38 Fixed in 1.44.38 Patch available GHSA-747p-wmpv-9c78
Remediation
- Fix · GHSA-747p-wmpv-9c78 awscli (PyPI) Fixed in 1.44.38 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-747p-wmpv-9c78
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences