Read the docs
TI-2026-66287 Aliases GHSA-vw5v-4f2q-w9xf

AWS-LC has PKCS7_verify Certificate Chain Validation Bypass

Priority LOW 38CWE-295Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Spoofing
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-295.

Summary

### Summary AWS-LC is an open-source, general-purpose cryptographic library. ### Impact Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. aws-lc-sys contains code from AWS-LC. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys. #### Impacted versions: aws-lc-sys versions: >= 0.24.0, < 0.38.0 ### Patches The patch is included in v0.38.0 ### Workarounds There is no workaround. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys. ### Resources If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via the [vulnerability reporting page](https://aws.amazon.com/security/vulnerability-reporting) or directly via email to [[email protected]](mailto:[email protected]). Please do not create a public GitHub issue. ### Acknowledgement AWS-LC would like to thank Joshua Rogers (https://joshua.hu/) for collaborating on this issue through the coordinated vulnerability disclosure process.

Why it matters now

Fix Fixed aws-lc-sys (crates.io): 0.38.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—aws-lc-sys (crates.io)0.24.0 to before 0.38.00.38.0Patch availableGHSA-vw5v-4f2q-w9xf
  • aws-lc-sys (crates.io) Vendor— Affected 0.24.0 to before 0.38.0 Fixed in 0.38.0 Patch available GHSA-vw5v-4f2q-w9xf

Remediation

  • Fix · GHSA-vw5v-4f2q-w9xf aws-lc-sys (crates.io) Fixed in 0.38.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vw5v-4f2q-w9xf

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences