Read the docs
TI-2026-66342 Aliases GHSA-j425-whc4-4jgc

OpenClaw's `system.run` env override filtering allowed dangerous helper-command pivots

Priority LOW 38CWE-15Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-639.

Summary

### Summary `system.run` env override sanitization allowed dangerous override-only helper-command pivots to reach subprocesses. A caller who could invoke `system.run` with `env` overrides could bypass allowlist/approval intent by steering an allowlisted tool through helper-command or config-loading environment variables such as `GIT_SSH_COMMAND`, editor/pager hooks, and `GIT_CONFIG_*` / `NPM_CONFIG_*`. ### Affected Packages / Versions - Package: `openclaw` (npm) - Latest published vulnerable version: `2026.3.2` - Affected range: `<= 2026.3.2` - Patched in: `2026.3.7` ### Details Before the fix, `src/infra/host-env-security.ts` blocked only a narrow set of override-only environment variables. Dangerous request-scoped overrides such as `GIT_SSH_COMMAND` and prefix families such as `GIT_CONFIG_*` and `NPM_CONFIG_*` could still survive `sanitizeSystemRunEnvOverrides(...)` / `sanitizeHostExecEnv(...)` and reach the spawned process. That mattered for `system.run` allowlist and approval flows because approval evaluation was tied to the reviewed binary/argv, while the launched process could still inherit attacker-controlled env overrides that changed helper-command execution or config resolution. For allowlisted tools such as `git`, this allowed behavior outside the reviewed command semantics. The fix extends the shared TypeScript and macOS policy to block dangerous override-only exact keys and prefixes while preserving trusted inherited base-environment behavior. ### Impact This is a real protection-bypass issue, but exploitation requires an already tool-enabled caller who can invoke `system.run` and supply `env` overrides. In affected deployments, that caller could bypass allowlist/approval intent and trigger helper-command execution or config-loading behavior that is not represented by the approved command line. Maintainer severity is set to medium because the bug still requires that existing execution capability; the vulnerability is the mismatch between reviewed command semantics and the actual spawned-process behavior. ### Fix Commit(s) - `e27bbe4982439da6864160fd1b66445058f74801` ### Release Process Note npm `2026.3.7` was published on March 8, 2026. This advisory is fixed in the released package. Thanks @tdjackey and @SnailSploit for reporting.

Why it matters now

Fix Fixed openclaw (npm): 2026.3.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—openclaw (npm)before 2026.3.72026.3.7Patch availableGHSA-j425-whc4-4jgc
  • openclaw (npm) Vendor— Affected before 2026.3.7 Fixed in 2026.3.7 Patch available GHSA-j425-whc4-4jgc

Remediation

  • Fix · GHSA-j425-whc4-4jgc openclaw (npm) Fixed in 2026.3.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-j425-whc4-4jgc

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences