Read the docs
TI-2026-66354 Aliases GHSA-gp3q-wpq4-5c5h

OpenClaw: LINE group allowlist scope mismatch with DM pairing-store entries

Priority LOW 38CWE-863Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.

Summary

### Summary In specific LINE configurations, sender IDs approved through DM pairing could also satisfy group allowlist checks when operators expected group sender access to be scoped only to explicit group allowlists. ### Affected Packages / Versions - Package: `openclaw` (npm) - Latest published version at triage/update time: `2026.2.25` - Affected: `<= 2026.2.25` - Patched: `>= 2026.2.26` (planned next release) ### Impact This is a group-authorization scope mismatch. DM pairing-store entries could influence group sender authorization in allowlist mode. ### Technical Details Root cause: group allowlist composition inherited pairing-store entries intended for DM approvals. Under default DM pairing policy, a DM-paired sender could match group allowlist checks. Fixes on `main`: - isolate group allowlist composition from pairing-store entries - centralize shared DM/group allowlist composition to preserve DM-only pairing behavior - add regression coverage for LINE and Mattermost policy paths ### Fix Commit(s) - `8bdda7a651c21e98faccdbbd73081e79cffe8be0` - `892a9c24b0f6118729ab5b5f5499b1a7e792dd15` (follow-up refactor hardening) ### Release Process Note `patched_versions` is pre-set to `>= 2026.2.26` so once npm `2026.2.26` is published, this advisory can be published directly without additional version-field edits. Thanks @tdjackey for reporting.

Why it matters now

Fix Fixed openclaw (npm): 2026.2.26

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—openclaw (npm)before 2026.2.262026.2.26Patch availableGHSA-gp3q-wpq4-5c5h
  • openclaw (npm) Vendor— Affected before 2026.2.26 Fixed in 2026.2.26 Patch available GHSA-gp3q-wpq4-5c5h

Remediation

  • Fix · GHSA-gp3q-wpq4-5c5h openclaw (npm) Fixed in 2026.2.26 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-gp3q-wpq4-5c5h

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences