Postiz App has a High-Severity SSRF Vulnerability via Next.js
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- No fix listed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact A successful SSRF attack allows an attacker to: - Bypass firewalls to scan and interact with internal network services/ports. - Access sensitive cloud metadata services (e.g., AWS IMDS 169.254.169.254) to potentially leak instance credentials. - Pivot into the internal network environment where Postiz is hosted. ### Workarounds There are no workarounds known to this, please upgrade to Postiz version `v2.21.1`.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | postiz (npm) | up to 2.0.12 | — | No fix listed | GHSA-vj2p-7pgw-g2wf |
- postiz (npm) Vendor— Affected up to 2.0.12 Fixed in — No fix listed GHSA-vj2p-7pgw-g2wf
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-03 Threatist record created from GHSA-vj2p-7pgw-g2wf
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences