Read the docs
TI-2026-66450 Aliases GHSA-w673-8fjw-457c

n8n: Authenticated XSS and Open Redirect via Form Node

Priority LOW 38CWE-601Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Spoofing, Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-601 and CWE-79.

Summary

## Impact An authenticated user with permission to create or modify workflows could configure a Form Node with an unsanitized HTML description field or exploit an overly permissive iframe sandbox policy to perform stored cross-site scripting or redirect end users visiting the form to an arbitrary external URL. The vulnerability could be used to facilitate phishing attacks. ## Patches The issue has been fixed in n8n versions 1.123.24, 2.10.4 and 2.12.0. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Form node by adding `n8n-nodes-base.form` to the `NODES_EXCLUDE` environment variable. - Disable the Form Trigger node by adding `n8n-nodes-base.formTrigger` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Fix Fixed n8n (npm): 2.12.0, 2.10.4, 1.123.24

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—n8n (npm)2.11.0 to before 2.12.02.12.0Patch availableGHSA-w673-8fjw-457c
—n8n (npm)2.0.0-rc.0 to before 2.10.42.10.4Patch availableGHSA-w673-8fjw-457c
—n8n (npm)before 1.123.241.123.24Patch availableGHSA-w673-8fjw-457c
  • n8n (npm) Vendor— Affected 2.11.0 to before 2.12.0 Fixed in 2.12.0 Patch available GHSA-w673-8fjw-457c
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.10.4 Fixed in 2.10.4 Patch available GHSA-w673-8fjw-457c
  • n8n (npm) Vendor— Affected before 1.123.24 Fixed in 1.123.24 Patch available GHSA-w673-8fjw-457c

Remediation

  • Fix · GHSA-w673-8fjw-457c n8n (npm) Fixed in 2.12.0 Advisory →
  • Fix · GHSA-w673-8fjw-457c n8n (npm) Fixed in 2.10.4 Advisory →
  • Fix · GHSA-w673-8fjw-457c n8n (npm) Fixed in 1.123.24 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w673-8fjw-457c

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences