n8n has XSS in Chat Trigger Node through Custom CSS
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
## Impact An authenticated user with permission to create or modify workflows could inject malicious JavaScript into the Custom CSS field of the Chat Trigger node. Due to a misconfiguration in the `sanitize-html` library, the sanitization could be bypassed, resulting in stored XSS on the public chat page. Any user visiting the chat URL would be affected. ## Patches The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. ## Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Chat Trigger node by adding `@n8n/n8n-nodes-langchain.chatTrigger` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | n8n (npm) | before 1.123.27 | 1.123.27 | Patch available | GHSA-3c7f-5hgj-h279 |
| — | n8n (npm) | 2.14.0 to before 2.14.1 | 2.14.1 | Patch available | GHSA-3c7f-5hgj-h279 |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.13.3 | 2.13.3 | Patch available | GHSA-3c7f-5hgj-h279 |
- n8n (npm) Vendor— Affected before 1.123.27 Fixed in 1.123.27 Patch available GHSA-3c7f-5hgj-h279
- n8n (npm) Vendor— Affected 2.14.0 to before 2.14.1 Fixed in 2.14.1 Patch available GHSA-3c7f-5hgj-h279
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.13.3 Fixed in 2.13.3 Patch available GHSA-3c7f-5hgj-h279
Remediation
- Fix · GHSA-3c7f-5hgj-h279 n8n (npm) Fixed in 1.123.27 Advisory →
- Fix · GHSA-3c7f-5hgj-h279 n8n (npm) Fixed in 2.14.1 Advisory →
- Fix · GHSA-3c7f-5hgj-h279 n8n (npm) Fixed in 2.13.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-3c7f-5hgj-h279
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences