Read the docs
TI-2026-66473 Aliases GHSA-h3m5-p59h-x88p

openssl-encrypt has visible password in process list via --password CLI argument

Priority LOW 38CWE-256Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-256.

Summary

### Summary Passwords passed via the `--password` / `-p` CLI argument in `openssl_encrypt/modules/crypt_cli_subparser.py` at **lines 150-154** are visible to any user on the system via `ps aux` or `/proc/[pid]/cmdline`. ### Affected Code ```python subparser.add_argument( "--password", "-p", help="Password (will prompt if not provided, or use CRYPT_PASSWORD environment variable)", ) ``` Similarly, `--keystore-password` exposes the keystore password. ### Impact On multi-user systems, any user can observe the encryption password by listing processes. The `CRYPT_PASSWORD` environment variable alternative is also visible via `/proc/[pid]/environ` (though with slightly restricted access). ### Recommended Fix - Document the security implications prominently - Recommend interactive prompting (already supported) as the secure default - Consider supporting password file descriptors (`--password-fd`) or reading from stdin - Consider marking the argument as deprecated in favor of interactive prompting ### Fix Fixed in commit `e78a366` on branch `releases/1.4.x` — added --password-file and --password-fd arguments; added OPENSSL_ENCRYPT_PASSWORD env var support; --password now emits deprecation warning.

Why it matters now

Fix Fixed openssl-encrypt (PyPI): 1.4.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—openssl-encrypt (PyPI)before 1.4.01.4.0Patch availableGHSA-h3m5-p59h-x88p
  • openssl-encrypt (PyPI) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-h3m5-p59h-x88p

Remediation

  • Fix · GHSA-h3m5-p59h-x88p openssl-encrypt (PyPI) Fixed in 1.4.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-h3m5-p59h-x88p

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences