Read the docs
TI-2026-66506 Aliases GHSA-fmg6-246m-9g2v

Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

Priority LOW 38CWE-331Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? You are affected if you meet the following preconditions: - Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0 - Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

Why it matters now

Fix Fixed auth0/login (Packagist): 7.21.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/login (Packagist)7.0.0 to before 7.21.07.21.0Patch availableGHSA-fmg6-246m-9g2v
  • auth0/login (Packagist) Vendor— Affected 7.0.0 to before 7.21.0 Fixed in 7.21.0 Patch available GHSA-fmg6-246m-9g2v

Remediation

  • Fix · GHSA-fmg6-246m-9g2v auth0/login (Packagist) Fixed in 7.21.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-fmg6-246m-9g2v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences