Read the docs
TI-2026-66507 Aliases GHSA-vfpx-q664-h93m

Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption

Priority LOW 38CWE-331Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? Consumers are affected if their application meets the following preconditions: - It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0 - Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/wordpress to version 5.6.0 or greater.

Why it matters now

Fix Fixed auth0/wordpress (Packagist): 5.6.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/wordpress (Packagist)5.0.0-BETA0 to before 5.6.05.6.0Patch availableGHSA-vfpx-q664-h93m
  • auth0/wordpress (Packagist) Vendor— Affected 5.0.0-BETA0 to before 5.6.0 Fixed in 5.6.0 Patch available GHSA-vfpx-q664-h93m

Remediation

  • Fix · GHSA-vfpx-q664-h93m auth0/wordpress (Packagist) Fixed in 5.6.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vfpx-q664-h93m

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences