Read the docs
TI-2026-66508 Aliases GHSA-ghc5-95c2-vwcv

Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption

Priority LOW 38CWE-331Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? Consumers are affected if their application meets the following preconditions: - It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0 - Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.

Why it matters now

Fix Fixed auth0/symfony (Packagist): 5.8.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/symfony (Packagist)5.0.0 to before 5.8.05.8.0Patch availableGHSA-ghc5-95c2-vwcv
  • auth0/symfony (Packagist) Vendor— Affected 5.0.0 to before 5.8.0 Fixed in 5.8.0 Patch available GHSA-ghc5-95c2-vwcv

Remediation

  • Fix · GHSA-ghc5-95c2-vwcv auth0/symfony (Packagist) Fixed in 5.8.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-ghc5-95c2-vwcv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences