Read the docs
TI-2026-66541 Aliases GHSA-q4gf-8mx6-v5v3

Next.js has a Denial of Service with Server Components

Priority LOW 38CWE-770Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-770.

Summary

A vulnerability affects certain React Server Components packages for versions 19.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23869](https://github.com/facebook/react/security/advisories/GHSA-479c-33wc-g2pg). You can read more about this advisory our [this changelog](https://vercel.com/changelog/summary-of-cve-2026-23869). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage. This can result in denial of service in unpatched environments.

Why it matters now

Fix Fixed next (npm): 15.5.15, 16.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—next (npm)13.0.0 to before 15.5.1515.5.15Patch availableGHSA-q4gf-8mx6-v5v3
—next (npm)16.0.0-beta.0 to before 16.2.316.2.3Patch availableGHSA-q4gf-8mx6-v5v3
  • next (npm) Vendor— Affected 13.0.0 to before 15.5.15 Fixed in 15.5.15 Patch available GHSA-q4gf-8mx6-v5v3
  • next (npm) Vendor— Affected 16.0.0-beta.0 to before 16.2.3 Fixed in 16.2.3 Patch available GHSA-q4gf-8mx6-v5v3

Remediation

  • Fix · GHSA-q4gf-8mx6-v5v3 next (npm) Fixed in 15.5.15 Advisory →
  • Fix · GHSA-q4gf-8mx6-v5v3 next (npm) Fixed in 16.2.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-q4gf-8mx6-v5v3

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences