aiograpi has dependency on vulnerable orjson 3.11.4 (CVE-2025-67221)
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-770.
Summary
## Impact aiograpi 0.6.6 / 0.7.0 / 0.7.1 declared `orjson==3.11.6` (and later `==3.11.8`) in `requirements.txt` but `setup.py` carried a hard-coded duplicate `requirements = [...]` list that was never updated and still pinned `orjson==3.11.4`. When `setuptools` builds the source distribution it reads the metadata from `setup.py`, not from `requirements.txt`. So `pip install aiograpi==0.6.6` (or 0.7.0 / 0.7.1) actually pulls `orjson==3.11.4` — a version vulnerable to **CVE-2025-67221** (stack overflow in `orjson.dumps` on deeply nested JSON inputs). ## Practical exploitability Low in the typical aiograpi flow: `orjson` is used to encode request bodies aiograpi itself constructs and to decode responses returned by Instagram. An attacker would need to coerce aiograpi to encode an attacker-controlled deeply-nested Python structure or to decode an attacker-supplied stream — not the normal call shape. However any caller doing `client.public_request(...)` or similar with caller-controlled payloads, or any caller passing aiograpi-decoded `last_json` into recursive serialization, may hit the unbounded recursion. The patched orjson rejects deeply-nested inputs cleanly. ## Patches Fixed in **aiograpi 0.7.2** by migrating to `pyproject.toml` (PEP 621) — single source of truth for dependencies. PyPI installs of 0.7.2 and later resolve `orjson==3.11.8` correctly. ## Workarounds Force-install a non-vulnerable orjson alongside the affected aiograpi version: ``` pip install 'aiograpi==0.7.1' 'orjson>=3.11.6' ``` Or just upgrade to a fixed aiograpi: ``` pip install -U 'aiograpi>=0.7.2' ``` ## Resources - orjson CVE-2025-67221 advisory: https://github.com/ijl/orjson/security/advisories - aiograpi 0.7.2 changelog (security section): https://github.com/subzeroid/aiograpi/blob/main/CHANGELOG.md#072--2026-04-27
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | aiograpi (PyPI) | 0.6.6 to before 0.7.2 | 0.7.2 | Patch available | GHSA-7mw3-79jq-xc7f |
- aiograpi (PyPI) Vendor— Affected 0.6.6 to before 0.7.2 Fixed in 0.7.2 Patch available GHSA-7mw3-79jq-xc7f
Remediation
- Fix · GHSA-7mw3-79jq-xc7f aiograpi (PyPI) Fixed in 0.7.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-7mw3-79jq-xc7f
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences