Read the docs
TI-2026-66697 Aliases GHSA-22vx-2x23-98w6

OpenSearch vulnerable to improper authorization for Rollover Requests

Priority LOW 38CWE-863Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.

Summary

### Description A flaw was identified in the OpenSearch Security plugin's handling of index rollover requests. When a rollover request included an explicit target index name, the security plugin did not properly evaluate access control permissions against the target index. This could allow a user with rollover permissions on a source index to create a new index with a name they are not authorized to use. ### Impact A user with `indices:admin/rollover` permission on a source index pattern could roll over to a target index name outside their authorized index patterns. This is limited to index creation via the rollover API and requires the user to already have rollover privileges on the source index. ### Patches This issue is fixed in OpenSearch 2.19.4 and 3.2.0 ### Workarounds Grant the `indices:admin/rollover` permission only to fully trusted users.

Why it matters now

Fix Fixed org.opensearch.plugin:opensearch-security (Maven): 2.19.4.0, 3.2.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—org.opensearch.plugin:opensearch-security (Maven)1.0.0 to before 2.19.4.02.19.4.0Patch availableGHSA-22vx-2x23-98w6
—org.opensearch.plugin:opensearch-security (Maven)3.0.0 to before 3.2.0.03.2.0.0Patch availableGHSA-22vx-2x23-98w6
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 1.0.0 to before 2.19.4.0 Fixed in 2.19.4.0 Patch available GHSA-22vx-2x23-98w6
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 3.0.0 to before 3.2.0.0 Fixed in 3.2.0.0 Patch available GHSA-22vx-2x23-98w6

Remediation

  • Fix · GHSA-22vx-2x23-98w6 org.opensearch.plugin:opensearch-security (Maven) Fixed in 2.19.4.0 Advisory →
  • Fix · GHSA-22vx-2x23-98w6 org.opensearch.plugin:opensearch-security (Maven) Fixed in 3.2.0.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-22vx-2x23-98w6

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences