OpenSearch Security plugin: DLS not applied on documents linked by has_child or has_parent relation
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.
Summary
### Description A flaw was identified in the OpenSearch Security plugin's document-level security (DLS) implementation. DLS restrictions were not correctly applied to search queries that use has_parent or has_child join relations. This could allow an authenticated user to access document contents that should have been restricted by DLS rules. ### Impact An authenticated user with access to an index containing parent/child join relations could bypass DLS restrictions on documents linked by those relations, potentially accessing restricted document contents. This only affects clusters that use both DLS and the `join` field type on the same index. ### Patches This issue is fixed in OpenSearch `2.19.4` and `3.2.0`. ### Workarounds Avoid using the `join` field type on indices that are subject to DLS rules.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | org.opensearch.plugin:opensearch-security (Maven) | 1.0.0 to before 2.19.4.0 | 2.19.4.0 | Patch available | GHSA-x83w-23jp-g6pw |
| — | org.opensearch.plugin:opensearch-security (Maven) | 3.0.0 to before 3.2.0.0 | 3.2.0.0 | Patch available | GHSA-x83w-23jp-g6pw |
- org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 1.0.0 to before 2.19.4.0 Fixed in 2.19.4.0 Patch available GHSA-x83w-23jp-g6pw
- org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 3.0.0 to before 3.2.0.0 Fixed in 3.2.0.0 Patch available GHSA-x83w-23jp-g6pw
Remediation
- Fix · GHSA-x83w-23jp-g6pw org.opensearch.plugin:opensearch-security (Maven) Fixed in 2.19.4.0 Advisory →
- Fix · GHSA-x83w-23jp-g6pw org.opensearch.plugin:opensearch-security (Maven) Fixed in 3.2.0.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-x83w-23jp-g6pw
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences