Read the docs
TI-2026-66699 Aliases GHSA-x5hg-x4gv-j98m

OpenSearch has ineffective TLS certificate hostname verification

Priority LOW 38CWE-295Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Spoofing
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-295.

Summary

### Description A regression was introduced in OpenSearch 2.18.0 that caused the `plugins.security.ssl.transport.enforce_hostname_verification` setting to be ineffective. When this setting was enabled, OpenSearch did not verify that the hostname in a connecting node's TLS certificate matched the hostname of the connection. This could allow a node with a valid certificate (signed by the cluster's trusted CA) but an incorrect hostname SAN to join the cluster. ### Impact Clusters running affected versions with hostname verification enabled did not receive the expected protection from this setting. A node presenting a certificate signed by the cluster's trusted CA could join the cluster regardless of whether its hostname SAN matched. This regression does not affect certificate validation itself — only the additional hostname verification check. ### Patches This issue is fixed in OpenSearch 2.19.4 and 3.3.0. ### Workarounds Use more restrictive values for `plugins.security.nodes_dn` to limit which certificates are accepted for node-to-node communication.

Why it matters now

Fix Fixed org.opensearch.plugin:opensearch-security (Maven): 2.19.4.0, 3.3.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—org.opensearch.plugin:opensearch-security (Maven)2.18.0 to before 2.19.4.02.19.4.0Patch availableGHSA-x5hg-x4gv-j98m
—org.opensearch.plugin:opensearch-security (Maven)3.0.0 to before 3.3.0.03.3.0.0Patch availableGHSA-x5hg-x4gv-j98m
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 2.18.0 to before 2.19.4.0 Fixed in 2.19.4.0 Patch available GHSA-x5hg-x4gv-j98m
  • org.opensearch.plugin:opensearch-security (Maven) Vendor— Affected 3.0.0 to before 3.3.0.0 Fixed in 3.3.0.0 Patch available GHSA-x5hg-x4gv-j98m

Remediation

  • Fix · GHSA-x5hg-x4gv-j98m org.opensearch.plugin:opensearch-security (Maven) Fixed in 2.19.4.0 Advisory →
  • Fix · GHSA-x5hg-x4gv-j98m org.opensearch.plugin:opensearch-security (Maven) Fixed in 3.3.0.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-x5hg-x4gv-j98m

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences