Read the docs
TI-2026-66737 Aliases GHSA-8h8q-6873-q5fj

Next.js Vulnerable to Denial of Service with Server Components

Priority LOW 38CWE-770Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-770.

Summary

A vulnerability affects certain React Server Components packages for versions 19.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23870](https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage. This can result in denial of service in unpatched environments.

Why it matters now

Fix Fixed next (npm): 15.5.16, 16.2.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—next (npm)13.0.0 to before 15.5.1615.5.16Patch availableGHSA-8h8q-6873-q5fj
—next (npm)16.0.0 to before 16.2.516.2.5Patch availableGHSA-8h8q-6873-q5fj
  • next (npm) Vendor— Affected 13.0.0 to before 15.5.16 Fixed in 15.5.16 Patch available GHSA-8h8q-6873-q5fj
  • next (npm) Vendor— Affected 16.0.0 to before 16.2.5 Fixed in 16.2.5 Patch available GHSA-8h8q-6873-q5fj

Remediation

  • Fix · GHSA-8h8q-6873-q5fj next (npm) Fixed in 15.5.16 Advisory →
  • Fix · GHSA-8h8q-6873-q5fj next (npm) Fixed in 16.2.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-8h8q-6873-q5fj

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences