Read the docs
TI-2026-66738 Aliases GHSA-w94c-4vhp-22gx

@vitejs/plugin-rsc has a Denial of Service Vulnerability in React Server Components

Priority LOW 38CWE-770Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-770.

Summary

### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.6. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

Why it matters now

Fix Fixed @vitejs/plugin-rsc (npm): 0.5.26

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@vitejs/plugin-rsc (npm)before 0.5.260.5.26Patch availableGHSA-w94c-4vhp-22gx
  • @vitejs/plugin-rsc (npm) Vendor— Affected before 0.5.26 Fixed in 0.5.26 Patch available GHSA-w94c-4vhp-22gx

Remediation

  • Fix · GHSA-w94c-4vhp-22gx @vitejs/plugin-rsc (npm) Fixed in 0.5.26 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w94c-4vhp-22gx

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences