Setup PHP: GitHub tokens configured by setup-php may be exposed through pinned affected Composer versions
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-532.
Summary
### Impact This affects only workflows that pin an exact affected Composer semver version through setup-php, for example `tools: composer:2.9.7`. Workflows using the default Composer version, `composer:v2`, or no pinned Composer version are not affected through setup-php, because those Composer URLs have been updated to patched Composer releases for all setup-php versions. setup-php does not directly print the token. The token may be exposed through Composer when Composer validates github-oauth auth and rejects GitHub's newer hyphen-containing token format. Public repository logs may expose the token. GitHub-hosted runner GITHUB_TOKEN values expire after the job, but exposure may still matter during the token lifetime and for longer-lived GitHub App or user tokens. ### Patches setup-php 2.37.1 skips generated GitHub OAuth auth for pinned Composer versions affected by Composer GHSA-f9f8-rm49-7jv2 while preserving other Composer auth, including Packagist auth. ### Workarounds Upgrade to setup-php `2.37.1` or newer. You can also avoid the affected path by using a patched Composer version: 2.9.8, 2.2.28, 1.10.28, or newer supported Composer releases. It is recommended to avoid pinning affected Composer versions such as `composer:2.9.7`, unless you have automations to do timely updates in your workflows.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | shivammathur/setup-php (GitHub Actions) | before 2.37.1 | 2.37.1 | Patch available | GHSA-5wxr-w449-57cm |
- shivammathur/setup-php (GitHub Actions) Vendor— Affected before 2.37.1 Fixed in 2.37.1 Patch available GHSA-5wxr-w449-57cm
Remediation
- Fix · GHSA-5wxr-w449-57cm shivammathur/setup-php (GitHub Actions) Fixed in 2.37.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5wxr-w449-57cm
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences